Oracle
Allen 2022-11-09 12:06:43 18466 0 0 0 0
Oracle19c,Oracle8i,Oracle10g,Oracle版本,Oracle兼容,Oracle19c与各版本客户端兼容情况测试,从官方资料看出,Oracle19c只支持11.2以上版本。但实际测试,Oracle10g,Oracle8i都是可以链接Oralce19c

官方资料如下图:

Oracle19c客户端各版本兼容情况

从官方资料看出,Oracle19c只支持11.2以上版本。

但实际测试,Oracle10g,Oracle8i都是可以链接Oralce19c

测试如下:

Oracle10g

Oracle 10g客户端
D:\>sqlplus system/123@orcl

SQL*Plus: Release 10.2.0.1.0 - Production on 星期三 11月 9 10:05:58 2022

Copyright (c) 1982, 2005, Oracle.  All rights reserved.


连接到:
Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production

SQL> select instance_name,status from v$instance;

INSTANCE_NAME                    STATUS
-------------------------------- ------------------------
orcl                             OPEN

SQL>

Oracle8i

Oracle8客户端也可以连接19c

C:\Documents and Settings\Administrator>sqlplus system/123@orcl

SQL*Plus: Release 8.1.6.0.0 - Production on 星期三 11月 9 09:56:08 2022

(c) Copyright 1999 Oracle Corporation.  All rights reserved.


连接到:
Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production

SQL> select instance_name,status from v$instance;

INSTANCE_NAME    STATUS
---------------- ------------
orcl             OPEN

SQL>

Tag: Oracle19c Oracle8i Oracle10g Oracle版本 Oracle兼容
我也要发一个   ·   返回首页   ·   返回[Oracle]   ·   前一个   ·   下一个
欢迎评论
未登录,
请先 [ 注册 ] or [ 登录 ]
(一分钟即可完成注册!)
返回首页     ·   返回[Oracle]   ·   返回顶部